Why the error “Unable to upgrade. (E2)”?

Why do I get the error “Unable to upgrade. (E2)” when I try to assign “next upgrade” to a wayspot contribution?

This has been a bug for nominations that are “in voting” ever since “Upgrade Next” was removed as an option and then added back because some users wanted it. You can still manually “Upgrade” the nomination when you earn one. Turn OFF automatically apply upgrades in settings.

The Wayfarer Discussion Discord has a tag written up about this error:

Cannot Upgrade Next a nomination with error code E2
Currently, you cannot mark nominations that are In Voting as Upgrade Next. If you want to upgrade a nomination that is already in voting, you can still do it this way:

  1. Go to Settings in Wayfarer and turn OFF “Automatically Apply Upgrades”
  2. Earn an Upgrade through reviewing
  3. Upgrade the nomination using “Upgrade” instead of “Upgrade Next”

The nomination will immediately be upgraded after pressing “Upgrade”.

1 Like

I currently have this problem it was ok last time I upgraded a nomination in voting. Now I get E2 error. Automatic upgrades are off and has been for a while.

You should only be getting the E2 message if you are trying to “Upgrade Next” and not if you have an upgrade to use and are tapping “Upgrade.” Can you share a screenshot showing that you have an Upgrade to use? Like this

Sure. Definitely pressing “upgrade”. New bug ?

i didn’t mark my answer as a solution and can’t figure out how to unmark this as solved.

Yea I bet niantics did it but it’s actually not solved. Probably ignored

i think it did solve the op’s problem. idk if you should do a separate post.

1 Like